1
Vote

Description HTML Field does not like a Calculated source field.

description

In order to circumvent the issue discussed in the WSS compatibility Discussion, I created a column in my list (DescriptionHTML). Its column type is Calculated. This field concatenates several field values together to form the site's address and contact information. The column values are being calculated correctly and it is a solid HTML text block. I've included the column's formula for testing purposes.
 
="Address:<br/>" & [Address] & "<br/>" & [City] & ", CA" & [Zip/Postal Code] & "<br/><br/>Phone: " & [Primary Phone]
 
The issue arises when this field (DescriptionHTML) is used in the web part. No errors occur, but the balloon renders excess text: string;#
 
After the excess text, the HTML from the column is rendered properly. This can be noticed by wrapping a <b> around all of the data - the column data appears bold, but "string;#" does not.
 
Also, if the same HTML comes from a "single line of text" column it renders properly without the excess text. So it seems of little doubt that it is the way the rendering mechanics are handling the particular Calculated column type.
 
Thanks for your help, Mike.
-Trey

comments

trov2k wrote Mar 4, 2009 at 10:39 PM

For clarity, I am running a WSS 3.0 environment and thus only the WSS map web part.

stephanrocks wrote Jul 23, 2009 at 7:41 PM

Hi there,

I'm getting the same issue. Does anyone have a resolve for this? I've tried RIGHT & LEN but they manipulate just the data before the "string;#" is added at the start.

The webpart works GREAT aside from this. :-)
  • Stephan

wrote Feb 14, 2013 at 6:36 PM