3
Vote

Google maps web part

description

After deploying the web part, i am able to use single point without any issues. However, when using the list, i get an error message that says "Go to the list settings page to delete these fields. "
 
Steps I took (Web Part Settings, also see attached image):
 
  • Placed the site path
  • Placed the list path
  • Bulding name "Content Type"
  • Field that holds "longitute" and "Latitude"
  • From the map centre, i picked the location name from the list.
     
    Utimately, when i applied the setting I get the following error message:
     
    One or more field types are not installed properly. Go to the list settings page to delete these fields.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
     
    Exception Details: System.Runtime.InteropServices.COMException: One or more field types are not installed properly. Go to the list settings page to delete these fields.
     
    Source Error:
     
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
     
    Stack Trace:
     
     
    [COMException (0x81020014): One or more field types are not installed properly. Go to the list settings page to delete these fields.]
    Microsoft.SharePoint.Library.SPRequestInternalClass.GetListItemDataWithCallback(String bstrUrl, String bstrListName, String bstrViewName, String bstrViewXml, SAFEARRAYFLAGS fSafeArrayFlags, ISP2DSafeArrayWriter pSACallback, ISPDataCallback pPagingCallback, ISPDataCallback pSchemaCallback) +0
    Microsoft.SharePoint.Library.SPRequest.GetListItemDataWithCallback(String bstrUrl, String bstrListName, String bstrViewName, String bstrViewXml, SAFEARRAYFLAGS fSafeArrayFlags, ISP2DSafeArrayWriter pSACallback, ISPDataCallback pPagingCallback, ISPDataCallback pSchemaCallback) +265
     
    [SPException: One or more field types are not installed properly. Go to the list settings page to delete these fields.]
    Microsoft.SharePoint.Library.SPRequest.GetListItemDataWithCallback(String bstrUrl, String bstrListName, String bstrViewName, String bstrViewXml, SAFEARRAYFLAGS fSafeArrayFlags, ISP2DSafeArrayWriter pSACallback, ISPDataCallback pPagingCallback, ISPDataCallback pSchemaCallback) +373
    Microsoft.SharePoint.SPListItemCollection.EnsureListItemsData() +2191
    Microsoft.SharePoint.SPListItemCollection.Undirty() +41
    Microsoft.SharePoint.SPBaseCollection.System.Collections.IEnumerable.GetEnumerator() +110
    VSeWSS.MJB.Sharepoint.GoogleMaps.MapsWebPart.createDDL() +301
    VSeWSS.MJB.Sharepoint.GoogleMaps.MapsWebPart.MapScript() +813
    VSeWSS.MJB.Sharepoint.GoogleMaps.MapsWebPart.OnPreRender(EventArgs e) +23
    System.Web.UI.Control.PreRenderRecursiveInternal() +108
    System.Web.UI.Control.PreRenderRecursiveInternal() +224
    System.Web.UI.Control.PreRenderRecursiveInternal() +224
    System.Web.UI.Control.PreRenderRecursiveInternal() +224
    System.Web.UI.Control.PreRenderRecursiveInternal() +224
    System.Web.UI.Control.PreRenderRecursiveInternal() +224
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3394

file attachments

comments

BenWilcock wrote Mar 31, 2010 at 5:38 AM

Alas I'm having the same issue- single point works fine but as soon as i point to to a list i get "One or more field types are not installed properly. Go to the list settings page to delete these fields.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. " Have to go into SP designer and remove the webpart before i can get back to the page.
This occurs with both a custom list and the packaged google mpas list.

Was so excited about deploying this but will (patiently) wait for a solution if anyone has one???

wrote Apr 6, 2010 at 1:12 PM

panoone wrote Jun 29, 2010 at 4:52 AM

Guys the "Content Type" column is a reserved system field. You want to use the Title column (or whatever else you have designated) for the name of the Building/Location.

wrote Feb 14, 2013 at 6:36 PM